Back to Support

FlickrExport Upgrade FAQ

What are the system requirements for FlickrExport 4?

FlickrExport 4.1 requires OS X 10.6.8 or later and iPhoto 7.1.5 or Aperture 3.0 or later. Note that previous versions support older versions of OS X and iPhoto/Aperture, so be sure to check if you meet the new requirements before buying/upgrading.

How much does upgrading cost versus buying a new license for FlickrExport 4?

Upgrades can be purchased for half the price of a full license (iPhoto $19.95 -> $9.95, Aperture $24.95 -> $11.95).

I already own FlickrExport 1-3. How do I upgrade to FlickrExport 4?

Upgrading to FlickrExport 4 requires providing your old FlickrExport serial number to prove that you are eligible for the upgrade. You can go to our web store and enter your serial number there when placing your order to receive upgrade pricing.

I've lost track of my FlickrExport serial number. How do I retrieve it so I can upgrade to FlickrExport 4?

Visit our lost license page and enter the e-mail address you used to originally purchase FlickrExport. You will be sent an e-mail that includes your serial number and a link that will send you to our web store where you can place your order.

Can I upgrade an iPhoto license to an Aperture one, or vice versa?

No, your old license must be for the same photo application as the new one, e.g. a FlickExport for iPhoto 3.0 serial cannot be used to purchase FlickrExport for Aperture 4.0.

© Copyright Fat Cat Software 2006-2018. Website by Brent Cameron Design